UBOX3 S900 PRO black screen issue

Is there anyway to restore the firmware on ubox3 s900 pro model. I tried the killer23 method and unfortunately every time I plug in the sd card, the unit refuse to power on. Is phenoixcard work on s900
or we need something else? Any help would be appreciate

Comments

  • 535four535four Member
    edited June 2017
    Make sure the power supply is a 2 Amp unit not 500 mA.
  • The power supply is 1.5a that our orginal from the vendor.
  • The power supply is 1.5a that our orginal from the vendor.
    If you have a 2.A on hand please try it or use the Ubox2 one.
  • The power supply is 1.5 A , power seem to be good, don't have volt meter to check but seem like it is ok. The red light is steadily on
  • only have ubox3
  • The power supply is 1.5 A , power seem to be good, don't have volt meter to check but seem like it is ok. The red light is steadily on
    The red light is on, but the Unblock logo just staying there forever right? if that's the case. it's the power supply have not enough amp drive it.
  • I wish that is the case, the logo is not even there just a blank screen, I will try to get hold of someone else UBTV power supply to check, thanks for the advice
  • Have you try another TV, HDMI cable or use the av cable instead see what happen?
  • C/P:
    開機無顯示/停在"安博LOGO"/藍畫面
    1.請添加工程師Whatsapp : +852 67643560 或 Wechat : unblocktech
    3. 說明的盒子現時的狀況: (開機有燈無畫面/開機停在安博LOGO/開機藍畫面/開機不斷閃屏無法操作/或經常性hand機)
    2. 向工程師提供盒子底部MAC SN 相片,
    3.留下您的電郵,等待工程師回復
  • Thank will try that
  • edited July 2017
    I have a similar issue. Logo comes on for about a 30 secs, and then black screen appears. When I press mouse button, mouse arrow shows up and I can move it while screen is all black. Can I get some help please.
  • Unplug it and replug the power back or do a reset by use a pin push and hold then plug the power until see it boot then releas, if not work contact them.
Sign In or Register to comment.