Was there an update I'm not aware of? My unblock tech box wouldn't turn on

Hello,

I got this unblock tech box about two years ago and have been using this since. This model is the PRO I900 from Unblock Technology. I'm based in the US and got this for my parents but I can't seem to get it working. It was working fine yesterday night. They tried to turn it on but the box isn't turning on anymore. I tried unplugging and replugging both the HMDI/power cable, along with another outlet and different tv/monitor but it doesn't turn on. The remote is working fine with the light flickering. But the box isn't lighting up either, but I can feel the box being a little warm like it's on. I'm not sure whether the fuse in the box is out. Help please :(


Comments

  • ALL version boxes working. I would suggest try another power adaptor.

    Thanked by 1Chrono1231
  • I just tried it, it didn't work. I think the box isn't picking up the remote from turning it on or something. The box is just warm and the adapter is hot. Is there any other way?

  • 535four535four Member
    edited February 4

    Does the power light came ON? the power adapter you've tried should be at least 1.5 to 2A. even the box or the adapter is warm doesn't meant anything.

  • I just tried a output 12VDC 1000MA, it doesn't seem to turn out though. The light doesn't turn on or flicker. Just the remote light is turning on.

  • 535four535four Member
    edited February 6

    No, you'll need 5VDC and 1.5A to 2A. just look at the picture that you've uploaded. 12VDC will just toast the unit but hopefully not.

  • bamby8bamby8 Junior Member

    The ubox is probably faulty.

    Also if you used a 12V power adapter instead of 5 Volts, you may fried it to make matters worse!

  • Sorry for the late reply, I appreciate the answers. I'm currently ordering a new adapter to try it now. It's arrive sometime this week or next week.

    What is weird is that this adapter came with the box a while back. So I don't get what made it toast the box. It didn't turn on at all

  • Try this, may work:

    at the back of the Unblock box, there is a small hole for "reset". You need someone to help you to do this. Use a paper clip, insert in that reset hole until you feel you have press a micro switch. Keep it hold on there and ask someone to plug in the power for you. Wait for about 25 seconds, then release.

Sign In or Register to comment.